Задание №6
ID: 195

Анализ программ с условным оператором и логическими выражениями

Подбор параметра в условии

Ниже приведена программа, записанная на пяти языках программирования.

Бейсик Python
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s < A OR t > 8 THEN
    PRINT "YES"
ELSE
    PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())

if s < A or t > 8:
    print("YES")
else:
    print("NO")
Паскаль Алгоритмический язык
var s, t, A: integer;
begin
    readln(s);
    readln(t);
    readln(A);

    if (s < A) or (t > 8)
        then writeln('YES')
        else writeln('NO')
end.
алг
нач
цел s, t, A
ввод s
ввод t
ввод A

если s < A или t > 8
    то вывод "YES"
    иначе вывод "NO"
все
кон
C++
#include <iostream>
using namespace std;

int main() {
    int s, t, A;

    cin >> s;
    cin >> t;
    cin >> A;

    if (s < A || t > 8)
        cout << "YES";
    else
        cout << "NO";

    return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(-2, 5); (1, 9); (4, 8); (6, 3); (9, 10); (12, 6); (15, 1); (18, 8); (21, 4).

Укажите наибольшее целое значение параметра A, при котором для указанных входных данных программа напечатает «NO» ровно 4 раза.