Задание №16
ID: 401

Программирование: обработка последовательности чисел

Количество чисел известно

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех двузначных чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, затем сами числа. Количество чисел не превышает 1000, введённые числа не превышают 30 000.

Программа должна вывести одно число: сумму всех двузначных чисел, кратных 3.

Пример работы программы:

Входные данныеВыходные данные
6
9
12
45
100
27
8
84
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем количество чисел в последовательности.
  2. Создаём список b, куда будем добавлять только двузначные числа, которые делятся на 3.
  3. Для каждого введённого числа проверяем, что оно находится в диапазоне от 10 до 99.
  4. Дополнительно проверяем, что число делится на 3 без остатка.
  5. Если число подходит под оба условия, добавляем его в список с помощью append.
  6. В конце выводим сумму всех подходящих чисел с помощью функции sum.

Решение на Python:

n = int(input())  # считываем количество чисел
b = []  # создаём список для подходящих чисел

for i in range(n):  # повторяем ввод n раз
    a = int(input())  # считываем очередное число

    if 10 <= a <= 99 and a % 3 == 0:  # проверяем двузначность и кратность 3
        b.append(a)  # добавляем подходящее число в список

print(sum(b))  # выводим сумму подходящих чисел