Задание №16
ID: 406

Программирование: обработка последовательности чисел

Последовательность заканчивается числом 0

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, в десятичной записи которых есть цифра 5.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0. Число 0 является признаком окончания ввода и в последовательность не входит.

Программа должна вывести одно число: количество чисел, содержащих цифру 5.

Пример работы программы:

Входные данныеВыходные данные
15
42
506
77
95
0
3
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем первое число последовательности.
  2. Создаём список b, куда будем добавлять числа, в записи которых есть цифра 5.
  3. Пока не встретился ноль, переводим каждое число в строку и проверяем наличие символа '5'.
  4. Если цифра 5 есть в записи числа, добавляем число в список с помощью append.
  5. В конце выводим количество подходящих чисел с помощью функции len.

Решение на Python:

a = int(input())  # считываем первое число
b = []  # создаём список для подходящих чисел

while a != 0:  # обрабатываем числа до нуля
    if '5' in str(a):  # проверяем наличие цифры 5 в записи числа
        b.append(a)  # добавляем подходящее число в список

    a = int(input())  # считываем следующее число

print(len(b))  # выводим количество подходящих чисел