Задание №16
ID: 415

Программирование: обработка последовательности чисел

Количество чисел известно

Напишите программу, которая в последовательности натуральных чисел определяет среднее арифметическое чисел, кратных 3 и не кратных 9. Ответ нужно вывести с точностью до десятых.

Программа получает на вход количество чисел в последовательности, затем сами числа. Гарантируется, что в последовательности есть хотя бы одно подходящее число.

Программа должна вывести одно число: среднее арифметическое чисел, кратных 3 и не кратных 9.

Пример работы программы:

Входные данныеВыходные данные
5
6
9
12
18
24
14.0
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем количество чисел в последовательности.
  2. Создаём список b, куда будем добавлять числа, которые делятся на 3 и не делятся на 9.
  3. Для каждого введённого числа проверяем оба условия.
  4. Если число подходит, добавляем его в список с помощью append.
  5. После обработки всех чисел находим среднее арифметическое через sum(b) / len(b).
  6. В конце выводим результат с точностью до десятых.

Решение на Python:

n = int(input())  # считываем количество чисел
b = []  # создаём список для подходящих чисел

for i in range(n):  # повторяем ввод n раз
    a = int(input())  # считываем очередное число

    if a % 3 == 0 and a % 9 != 0:  # проверяем кратность 3 и отсутствие кратности 9
        b.append(a)  # добавляем подходящее число в список

print(round(sum(b) / len(b), 1))  # выводим среднее арифметическое с точностью до десятых