Задание №16
ID: 419

Программирование: обработка последовательности чисел

Количество чисел известно

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, у которых первая цифра меньше последней.

Программа получает на вход количество чисел в последовательности, затем сами числа. Количество чисел не превышает 1000, введённые числа не превышают 30 000.

Программа должна вывести одно число: сумму чисел, у которых первая цифра меньше последней.

Пример работы программы:

Входные данныеВыходные данные
5
123
54
807
19
71
142
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем количество чисел в последовательности.
  2. Создаём список b, куда будем добавлять числа, у которых первая цифра меньше последней.
  3. Для каждого числа находим первую цифру через str(a)[0], а последнюю цифру через остаток от деления на 10.
  4. Если первая цифра меньше последней, добавляем число в список с помощью append.
  5. В конце выводим сумму всех подходящих чисел с помощью функции sum.

Решение на Python:

n = int(input())  # считываем количество чисел
b = []  # создаём список для подходящих чисел

for i in range(n):  # повторяем ввод n раз
    a = int(input())  # считываем очередное число
    first = int(str(a)[0])  # находим первую цифру числа
    last = a % 10  # находим последнюю цифру числа

    if first < last:  # проверяем, что первая цифра меньше последней
        b.append(a)  # добавляем подходящее число в список

print(sum(b))  # выводим сумму подходящих чисел