Задание №16
ID: 409

Программирование: обработка последовательности чисел

Количество чисел известно

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, у которых сумма цифр больше 9.

Программа получает на вход количество чисел в последовательности, затем сами числа. Введённые числа не превышают 30 000.

Программа должна вывести одно число: количество чисел, у которых сумма цифр больше 9.

Пример работы программы:

Входные данныеВыходные данные
5
28
105
96
700
58
3
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем количество чисел в последовательности.
  2. Создаём список b, куда будем добавлять числа, у которых сумма цифр больше 10.
  3. Для каждого введённого числа создаём переменную s, в которой будем хранить сумму его цифр.
  4. Перебираем цифры числа по индексам через range(len(str(a))) и прибавляем каждую цифру к сумме.
  5. Если сумма цифр больше 10, добавляем число в список с помощью append.
  6. В конце выводим количество подходящих чисел с помощью функции len.

Решение на Python:

n = int(input())  # считываем количество чисел
b = []  # создаём список для подходящих чисел

for i in range(n):  # повторяем ввод n раз
    a = int(input())  # считываем очередное число
    s = 0  # создаём переменную для суммы цифр

    for j in range(len(str(a))):  # перебираем цифры числа по индексам
        s += int(str(a)[j])  # добавляем очередную цифру к сумме

    if s > 10:  # проверяем, что сумма цифр больше 10
        b.append(a)  # добавляем подходящее число в список

print(len(b))  # выводим количество подходящих чисел