Задание №16
ID: 411

Программирование: обработка последовательности чисел

Количество чисел известно

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, которое делится на 5 и содержит цифру 2.

Программа получает на вход количество чисел в последовательности, затем сами числа. В последовательности всегда имеется хотя бы одно подходящее число.

Программа должна вывести одно число: минимальное число, которое делится на 5 и содержит цифру 2.

Пример работы программы:

Входные данныеВыходные данные
5
125
40
220
25
72
25
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем количество чисел в последовательности.
  2. Создаём список b, куда будем добавлять числа, которые делятся на 5 и содержат цифру 2.
  3. Для каждого введённого числа проверяем кратность 5.
  4. Дополнительно переводим число в строку и проверяем, есть ли в его записи символ '2'.
  5. Если число подходит под оба условия, добавляем его в список с помощью append.
  6. После обработки всех чисел считаем первое число из списка начальным минимумом.
  7. Перебираем список b по индексам и находим минимальное подходящее число.
  8. В конце выводим найденный минимум.

Решение на Python:

n = int(input())  # считываем количество чисел
b = []  # создаём список для подходящих чисел

for i in range(n):  # повторяем ввод n раз
    a = int(input())  # считываем очередное число

    if a % 5 == 0 and '2' in str(a):  # проверяем кратность 5 и наличие цифры 2
        b.append(a)  # добавляем подходящее число в список

m = b[0]  # считаем первое подходящее число начальным минимумом

for i in range(len(b)):  # перебираем список по индексам
    if b[i] < m:  # проверяем, меньше ли текущее число минимума
        m = b[i]  # обновляем минимум

print(m)  # выводим минимальное подходящее число